Bold problem in MS Word

I have a normaln family and italics linked to their counterparts - and there is a problem in Word (Windows 7): Bold only appears in italics, and this happens in Word and the character map, but it does work properly in Photoshop. All weights work properly except “bold” where you only get
italics whether you want them or not.

‘Bold’ appears as available for selection from the menu-bar. When
selected, it displays as an italic.

If ‘Regular’ is selected, and then Word’s ‘bold’ option is applied, the
correct Bold font displays.

It looks like styling issue. How to fix it?

I can’t really help you without having a look at the font. Can you send me the .glyphs files?

Ok I got it. In the bold instance, in Style linking I had set a “Regular” word but none of checkboxes were selected. I thought, if a checkbox is not selected, it doesn’t matter whether there is something set to the input field or not.

When I deleted it, everything works fine.