Brace layers and anchors

I’m using brace layer for a variable font Axes where only few glyphs change, and it is working nice except that anchors don’t seem to interpolate and the attached mark glyphs keep the position of the default master.

Is this expected? If yes, is there a work around or an alternative other than using full masters?

I just tried this. It seems that intermediate deltas for anchors are not supported, yet. Neither by brace nor by full layers. I’ll have a look.

Edit: I have to correct myself. With full masters, it seems to work.

@GeorgSeifert this issue is still there in Glyphs 3.1 !
will it be solved anytime soon?

We are planing some bigger changes for the variable GPOS export. This will solve the problem. Not sure if I can manage to get this done with the old code base.

Great! So it will be implemented in version 3.2?
Any estimation on the release of this update?

Not sure yet.

It’d be great if you can manage to update it by the end of this year. Thank you.

Any updates on this? Thank you.

Hi @GeorgSeifert, I’ve sent you an email with a test file. Please let me know if you have got it.

I just had another look at it and I’m not sure I can get it to work in Glyphs 3.

So I shouldn’t wait for it?