Bracket layer in variable fonts

I’m trying to use the Bracket Trick and it’s working on the static instances, bot it’s not working on the variable font. The font has two axis, but I’m applying the substitution to a square portion of the design space.

Is there anything I should with Bracket Trick so it works on the variable font?



You need the bracket layer in all masters (even if you would never see those shapes).

1 Like

Georg, how does this work when there are lots of axes? If we want to replace a glyph when a particular axis (or combination of axes) exceeds a certain value, how do we tell Glyphs when to make the substitution?

yes, tried that. Even tried with only two masters and it didn’t work on variable fonts.
Since this set up works fine on static fonts I assumed it should work on the variable version two.

In Glyphs 2 you can only switch on the first axis.

It should work. Are all bracket layers compatible? Can you send me the file?

Thanks! And in G3?

I just added bracket layers to the masters that are not used, and it’s working now. I was probably doing something wrong before. Thanks!

@Bendy although it only works on the first axis, weight in my case, it affects all the design space within that weight range, so it’s not bad.

Anyway. I still think this is a convoluted way of making substitutions.
Would be great just to have the alternates as different glyphs, than have a parameter assigning where they are applied in the design space.


Hi guys, I’m having this issue with bracket layers on my type.
Basically I have 3 master, plus I set up a bracket layers for each one of those masters, as you can see in the attached image below!!

On the blackest master, I would like to drop the serif in order to gain a bit white space, contrast.

Now, If I test the behavior with OTVar player it seems to behave correctly. Instead, when I test it in indesign, fontGoggles, Safari, Chrome… it works partially. In particular, it works only on basic latin letters, every accented letter still show up still with the serif (component). Like in this attached image.

Could you please explain me, what am I doing wrong?
I tried to follow different discussion in this forum, but never come to the solution. I even tried the Composite Variabler script, but I didn’t get the expected result.

I’m working in Glyphs 2.6.6 (1350)
Thanks in advance

Looking forward to hear your reply, I still don’t understand what is wrong with the bracket in the accent letters.