Bracket layer switching defective when fonts are generated on an Intel Mac

The bracket layer switching is defective when the fonts are generated on an Intel Mac. When they are generated on an Apple processor the fonts are supposedly functional.

Is this something that will get fixed or not?

If I figure out what is causing this, I’ll fix it, of course.
What versions of glyphs and macOS do you have on each machine?

I’m running the cutting edge version of Glyphs, and that’s on MacOS 13.3.1 (a)
The bracket switching has not worked for many months. Greg got it working on the Apple processor Macs, and that was the last I heard.

Can you send me the file for testing?

Should be in your inbox now.

Any update on this?

I just exported the file you send me from my Intel macMini and the M1 mac and the result is exactly the same, at least the ttx files are.

If you email me the two TTFs then I can see if they make a difference in my test documents.

Just had a look, and they are the same because they are both broken. Greg got it working last time, but infamously not on Intel.

You will have to compare eg. this attached FontGoggles doc with Variable Font Preview in Glyphs. The way the glyphs are setup in Glyphs is correct, the way it renders in FontGoggles is not. The dollar glyph is especially advanced (and the switching in the in the “_dollar-bar” component)

Playfair diagonal switching (1.2 KB)

Still nowhere on this issue???

On what slider setting do you expect the alternate “v” to show up?

The same way as it is defined in Glyphs. The alternate is defined as such:

Screenshot 2023-05-28 at 10.01.05

And should behave like so:

I tried again the file I send you (the intel+arm) and it does work for me as expected. You need to consider that you have a rather extreme axis mapping on the optical size axis. The bracket layer definitions (seen in the screenshot) are with internal coordinates, the sliders in FontGoggles and such are in external coordinates as after the mapping. So the breakpoint on the optical size axis is something around “8.3” instead of “410”

The bracket switching is exactly setup as it should work in the finished fonts – with all re-mappings taken into account. This means that your example with 410 → 8.3 is correct.

If you look at this:

You can see that the alternative version of the glyphs are active where they should not be active. Again, the way they are setup in Glyphs is correct, but all the generated fonts are not working correctly.

In the example of the Roman ‘v’, the alternative design should only be activated where all the three defined ranges are active: 5<oz<410,50<wd<75,690<wg<900 concurrently.

I see.