BubbleKern, a new kerning tool

I don’t normally announce the tools I’ve made here in the forum, but I think this one might be of interest to many designers, so please allow me to share my excitement.

Meet BubbleKern, a set of scripts and viewer plugin that lets you draw the space around letterform in the extra layer called “bubble”. Once you do, the BubbleKern script automatically kerns your typeface.

You can download it from my GitHub repository, and read more about in my blog post (as well as the manual PDF that comes with the package). The manual may not be thorough which I may update, and I’ll upload a tutorial video in the future.

I’d like you to use it and hear your opinion on your experience.


That’s very interesting. I remember first discussing something similar (rectangular zones) to this concept with others in the late '70s, probably 1978, as an on-the-fly kerning mechanism for a particular brand of phototypesetting equipment. It wasn’t really feasible then, but the idea was there.

Given we were working with the very coarse 54-unit system in those days, it’s hard to say how much of an improvement, if any, it might have been. It would have slowed the equipment down quite a bit too, I think.

Today of course we have much better computers and software, and I look forward to trying it out. Thanks so much for making it available.

Thanks Toschi, it seems this could be a great helper, yet I have a problem. On my iMac everything is fine, but on my old MB Pro script “Make Bubble layers” do nothing.
Any clue why?

Do you use the latest version of the Glyphs? Some precious versions doesn’t do offset filter at all and deletes outline instead.


Know you what happened here?

You have way too much Kerning. About 10 times as much as an OTF can hold. Try the following:

  • consider deleting your kerning altogether and improving your spacing (LSB/RSB). Read the Spacing tutorial if you have not already.
  • get rid of small pairs. There are script for that in my GitHub repo, look in the Metrics submenu.
  • get rid of unnecessary/impossible pairs. E.g. did you kern Ldot to V?
  • get rid of kerning for certain glyphs. E.g. all pairs with symbols like .notdef and lozenge, or all tabular figures.
  • compress kerning to group kerning where possible, and get rid of exceptions.
  • add the Use Extension Kerning parameter to File > Font Info > Font > Custom Parameters.

And read the Kerning tutorial if you have not already.

PS: Why did you post in this thread?

1 Like

That means you have too much kerning (or a unfortunate structure).

1 Like

Ahhh, thanks.
I am still testing bubblekern. I thought that the problem came from bubblekern, and I had a part of reason…
I seen the kerning window and I had 300.000 pairs.
I think I made something wrong with the script.

For how many glyphs? I would consider a hundredth of that too much. You need to use Bubble Kern more selectively, of course.

1st. I opened a generated otf to test. I had no kerning groups. Bubblekern picked each character as an individual.
2º, I made combinations of everything with everything.
This is the reason of my error.

Thanks for your help. I thought that glyphs could generate illimited pairs.

Glyphs can generate, but OTF cannot hold unlimited pairs.

1 Like