Cannot click to change curser position in Text mode anymore


I am unable to change the curser position, like used to be possible. Seems to have happened since the last cutting edge update. I have also tried to disable plugins, but this does not fix the issue.

Not a huge inconvenience, but having it back would be good.

Running Mac Big Sur 11.5. Glyphs 3.0.4 (3098).


Does clicking to reposition the text cursor no longer work or are you unable to move it with the arrow keys? Could post a screenshot or a screencast showing the effect? And when did it stop working, after updating to the latest cutting edge or after that?

It is just clicking that no longer works. The arrow keys work fine.

In reference to when. I updated to Glyphs 3.0.4 (3098) and installed a trial of LTTR/INK at the same time. And it started happening after that, but I am not 100% sure if it was immediately after. I have since uninstalled LTTR/INK but the issue persists.

Screen Recording 2021-09-13 at (534.3 KB)

Thank you for the details and the screencast. Try to use the previous (3097) version. You can download it here:

Unzip it and launch it directly from your Downloads folder. On launch, Glyphs 3097 will ask you to move itself into the Application folder, but since you are just testing say no to that. If it does work in 3097 but not 3098, that would be very helpful for us to know.

Or maybe you switched mouse or are using a design tablet now?

I just installed the Trial to see how it would work with macOS 10.13.16 with [3098] and I get repeated crashing if I try to use Text Preview. The cursor works fine in all respects that I tried though.

Since it crashed with the plugin still active, reopening will only result in an immediate crash. Only way to get around that is to uninstall the plugin.

Crash report sent.

Just to make sure, you are talking about WindowText Preview, not WindowPreview Panel or the Preview Bar at the bottom of Edit View?

Yes. I opened the Preview Panel first, found no problems, so without closing that panel I opened Text Preview. That’s when the problems began.

I typed a word, moved the cursor around, then tried to select a new layer in the LetterInk selection at top left. That’s when the first crash happened.

I have tried 3097 with and without plugins. I am still unable to click to reposition the text cursor.

I have always used the trackpad, but I also tried with a mouse and still no luck.