Cannot create legacy marks (as comb marks are already in)


I am facing a strange issue. I already have in my file all the combining marks and I see myself unable to implement some of the legacy marks. Those one: grave dieresis acute cedilla circumflex dotaccent ring tilde. How could I get around this issue?

Thank you

ps. I am running Version 2.2.2 (824) on Mac.

In what way is it not possible? What happens when you add a legacy mark?

There is a section called Legacy Marks in this Tutorial:

Does this help?

When I create the legacy marks, they just dont appear. Second option, I have tried is to force renaming the comb marks into legacy; unsuccessful too.

That is the message I receive when I ask to create legacy marks.

That makes little sense to me. Does it to you?

What is you setting in File > Font Info > Other Settings > Custom Names? Your comb marks seem to carry the legacy Unicodes. Turn off custom names or update glyph info via the Glyph menu.

Thanks for the Font Info tip… but that doesn’t work :confused: The custom names was already unchecked.
And what is not making sense at all is that the comb marks have their correct unicode values in place. So, the message I posted earlier is wrong saying that the font contained glyphs with the same unicode… or I am missing something.

Here is an extract of my the Glyph Data I am using:

<glyph unicode="0301" name="acutecomb" category="Mark" subCategory="Nonspacing" production="acute" altNames="acute" description="COMBINING ACUTE" anchors="_top, top" />
<glyph unicode="0300" name="gravecomb" category="Mark" subCategory="Nonspacing" production="grave" altNames="grave" description="COMBINING GRAVE" anchors="_top, top" />
<glyph unicode="0327" name="cedillacomb" category="Mark" subCategory="Nonspacing" production="cedilla" altNames="cedilla" description="COMBINING CEDILLA" anchors="_bottom, bottom" />

you should not use acute, grave and so on as production names for your combining marks. You should remove the lines from your glyphData and it will work.