Cannot install Vanilla after recent Glyphs udate

I just updated Glyphs 3, which then advised me to install a new version of Python via the Plugin Manager, which I did.

Then the scripts that rely on Vanilla wouldn’t work any more. Trying to fix this, I un-installed Vanilla using the Plugin Manager, then tried to install Vanilla again (using the Plugin Manager), and got this Message:

What is the Application Support folder? And how do I “check the write permissions”?

It turns out even the scripts that don’t use Vanilla are not working any more. I am getting errors like this:

Traceback (most recent call last):
  File "runMacroFile", line 1
ModuleNotFoundError: No module named 'objc'
Traceback (most recent call last):
  File "NULL", line 1
NameError: name 'os' is not defined
Traceback (most recent call last):
  File "Jump to Alternate.py", line 16
    from AppKit import NSAttributedString, NSMutableAttributedString
ModuleNotFoundError: No module named 'AppKit'

So, the recent Glyphs update completely broke Python?

What Glyphs version are you using? Are you on the cutting edge? And what Python version is selected in GlyphsPreferences…Addons?

Thanks for your quick response!
I am using Glyphs 3097 and Python 3.9.1 (Glyphs).

Small update: After un-installing and re-installing Python again, Python macros in general are working again but I am still getting the same message if I try to install Vanilla using the Plugin Manager.

Choose ScriptOpen Scripts Folder. The Glyphs 3 folder will be shown in Finder with the Scripts folder selected. This Glyphs 3 folder is in a folder named Application Support.

Select a folder and press Command-I to show its info. At the bottom of the info window are the permissions of the folder. Could you please post screenshots of this info window for the Plugins and the Repositories folders in the Glyphs 3 folder and the info window of the Glyphs 3 folder itself.

I don’t think that a Glyphs update would change anything about that, but just to be sure.

Seems I found the problem!

In the Repositories folder there was already an empty subfolder named vanilla. For some reason it was not deleted when I removed Vanilla via the Plugin Manager.

After I deleted the vanilla subfolder the installation worked fine, and now everything is back to normal. Phew. It seems permissions were not the problem.

So, possible things to check in Glyphs are: (1) is the subfolder really deleted when uninstalling via the Plugin Manager? (2) When creating the subfolder fails, is the problem really permissions or a pre-existing subfolder (which, when trying to create it, raises a similar error as lack of permissions)?

2 Likes

Thank you for the observation. We’ll improve the deletion and error handing code in this regard.

1 Like