Cannot open Glyphs App

Please help. I cannot open the software. Here is my screenshot

Restarted few times, but still not working

Thanks

It seems like you have an outdated version of Glyphs 2. Redownload from the Get App page, and move the app into the Applications folder.

Also, are you using any antivirus or system maintenance tool like Mac Cleaner or the like? Please do not. It can break apps.

1 Like

Thank you:) I removed all scripts, and it worked!

Hi guys! I’m having the same problem. It just doesn’t open. I’ve uninstalled it, downloaded the most updated version from your website and it’s still crashing. Just as a test, I downloaded Glyphs Mini and it works.
Any ideas on how to sort this problem out?
Thanks!

Try the suggestions in this tutorial:
https://glyphsapp.com/tutorials/crashes

It keeps going to this page. I never get the option to report the problem.
I’ve also gone through all the next steps you mentioned and it didn’t work, unfortunately.

Can you send the next few lines from the Apple crash report?
And did you try to start with Option and Shift key pressed?

I’ve just sent the Apple crash report to support. I’ve also tried to Option+Shift and it didn’t work either :confused:

The crash report you sent indicates that a plug-in is causing the crash at startup. Try starting without plug-ins. Hold down Opt and Shift while you start the app. Or rename the Plugins folder.

In Finder choose Go > Go to Folder… and paste this line in the dialog that follows:

~/Library/Application Support/Glyphs/

Are you sure you are holding the right keys? Opt is sometimes labeled Alt or only has the ⌥ symbol on it.

Yes! Thank you, it worked! I did tried before to rename plugins to plugins OFF and didn’t work before for some reason. All working now. Thank you so much guys :pray:

Do you know what plugin caused the problem?

I had a look at the crash log. The “Arrange Windows” plugin causes the crash. Please get the latest version from Plugin Manager.

Helppp… my Glyphs app (version 2) is not responding suddenly, I’ve tried to restart many times but have to force quit. I try to download Glyphs 3 trial version and have no problem launching it. I would like to upgrade it to version 3, in this situation, can I still upgrade on top of my Glyphs 2…?

Thanks!

Hello @hrftype, welcome to the forum!

From the screenshot, I can see you are using version 2.6.4 (1286). Try the latest one: 2.6.7, build 1356. Move to the Applications folder after download and unpacking.

It seems to hang while trying to recreate the last opened windows. Consider starting without extensions and perhaps resetting prefs and clearing out Autosave info or Saved Application State, as explained in the Crashes tutorial.

And apparently you are using macOS 10.11.6. The system is supported, but it is pretty old, and does not support variable fonts at all. Therefore, I recommend upgrading to 10.13 (High Sierra) or better 10.14 (Mojave). You can download the installers from the Apple page ‘How to get old versions of macOS’. Your hardware should support those two easily.

Hope this helps.

1 Like

Thanks @mekkablue , it works now :smile: