Cannot paste selection (pixels) from Photoshop to Glyphs demo

I’m on Mac Monterey, using Photoshop 2022 latest, and Glyphs Trial.
I’m taking an online class with Rob Leuschke and so I know it can be done(!): He made a selection in Photoshop with the magic wand, and then pasted the pixels into Glyphs, so he could use it as a template to draw over. When I do the same thing, it doesn’t Paste anything into Photoshop. Is there something that makes it not work? I’ve tried changing the file from grayscale to RGB.

My workaround is to save the selection as a new JPG and drag in the image. Pasting would be faster though. Thanks!

I just tried it and it should work. Can you try flattening the image to the background and see if you can copy paste that?

Thanks for your reply. I fixed it on my a Mac Pro – I had disabled Pref > General > Export Clipboard a while back and must have forgotten (doh!). I guess I don’t have any need to paste outside of PS.

But on my new M1 laptop with a clean install of Photoshop I’m having a similar problem and the Export Clipboard preference is enabled (it’s the default).
I’m pasting a solid black letter T. When I paste, something is happening: In Glyphs, the grayed-out placeholder disappears and the Undo says “Undo > Add Image”, but the result is white.
BUT if I press the spacebar to move around the cell, the black image toggles to being visible! Is there a setting or preference I can enable to fix this?!

  • UPDATE: I found it. View > Show Image.

As a beginner, may I suggest that Show Image be enabled by default?