Cannot Run Any Scripts In Glyphs 3

I was not able to see scripts, but thanks to glyph forums it worked for me and I can see scripts now. Now I cannot use any of the scripts . I have updated my python and tried out so many solutions but whenever I run any script it responds nothing. I tried installing so many scripts but none worked for me. Somebody please help me asap, this is causing me huge trouble. Thank you in advance.

Can you check the macro window if you get any error message?

Can you help me with this ?

Also I cannot install filters, and use them ! And this keeps happening after I install a filter and restart my Glyphs.

You need to install all modules from : Plugin Manager > Modules

Hey, I have installed all of these already… :((

Can you check Preferences > Addone > Python version. Select entry that has “(Glyphs)” in the name.

Or install vanilla in the python installation that you use.

Can you please tell me, what version of python should I install, I got only this one. As you recommended this in a older forum ?

I run this in the terminal: pip3 install pyobjc. And now it keep loading and glyph crashes :frowning: @everyone

Please follow the steps in this tutorial:

Make sure the Python from the Plugin Manager is properly installed.

Can you run this in the terminal.


then in the python console.

import objc

What does it print?

If you can’t get Glyphs to start. Use this command in the Terminal to set the correct python version.

defaults write com.GeorgSeifert.Glyphs3 GSPythonFrameworkPath "/Users/XXXX/Library/Application Support/Glyphs 3/Repositories/GlyphsPythonPlugin/Python.framework/Versions/3.10"

You need to replace the XXXX with your user name. And You also need to try with a “9” instead of the “10” at this end.

Thank you both of you <3 . I tried both the solutions and reinstalled the glyphs trial, maybe the problem was due to I turned off incoming connection and I was using a cracked glyphs version idk. They are working now with a trial version. :(( Sorry as a student I cannot afford to have a glyphs, I just got a mac to use glyphs after 4 years of struggle. Thank you very much.

Better to ask for an extended trial license. The cracks break a few things in your system.