Can't Import UFOs with Glyphs on Lion

I just recently upgraded to OS X Lion. Today I tried to import a UFO into Glyphs. I get this error message: ‘The document “xxxx.ufo” could not be opened.’ I tried some other UFOs and got the same error.

After some experimenting, I discovered that Glyphs running on another Mac I have that’s still running Snow Leopard could open UFOs with no problem.

Is this a known bug?

can you send me the .ufo?

It’s not just one. I haven’t been able to open any UFOs in Glyphs on Lion so far.

Just sent one of my UFOs to your info@ address.

1 Like

You have to export it in a special way so that you get the Lion/Glyphs friendly UFO. Let me try it and refresh my memory on the right way. I will get back to you, Mark.

When I first tried it, I still had both 5.04 on a PPC and 5.1 on Lion. I would export the UFO in my old PPC and load it in to Glyphs on the new Lion machine. Since then, there is a better way.

BTW, did you reinstall Robothon with the new installation yet? This is required.

No RoboFab in not required. Only if you what to use it in scripts.

isn’t export to UFO a script?

It is a Script in FontLab. Glyph has native ufo support.

Maybe I missunderstand Mark’s problem. I assume he is exporting a ufo from FontLab to open in Glyphs. At any rate, I have just exported a UFO from Fontlab and Glyphs will not open it. However, that same ufo opens just fine in RoboFont. I don’t know where the problem lies. Is it with the way FontLab produces the UFO from the script, or is it what Glyphs requires to recognize the UFO?

I have just done some new testing. I tried opening every UFO file that I have from every source and none of them would open in Glyphs. Also, none of them would open in DTL OTMaster. They all opened just fine in Metrics Machine and RoboFont.
I tried one more thing. I took a native Glyphs file that was saved as .glyphs and opened it in Glyphs–this worked just fine. I then saved that file as UFO from inside Glyphs and then quit glyphs. I then tried to open that same UFO file that Glyphs had output in Glyphs but it would not open it. Once again RoboFont and Metrics Machine opened it just fine. If I double-click on the UFO in the finder, by default, it opens in Metrics Machine. I don’t know why.
Something changed since January 11, 2012 because this was working fine before and in Lion. I have no idea if this is Lion, Glyphs, or something else. Have there been any updates since January? The only thing I remember is loading the RMX Tools Beta but that does not seem like the probable culprit? I have not messed with any of the UFO3 stuff so that can’t be it.


All of the UFOS I’ve tried to open unsuccessfully in Glyphs on Lion were created prior to upgrading to Lion. Some of them are fairly old, going back as far as 2005. These same UFOs open with no trouble in Glyphs on Snow Leopard.

Chris: One of the main reasons behind UFO was to create a format that would be future-proof, that you could use it to archive font data in a form that was tool-agnostic. Having to go back to a .vfb in FontLab to re-export a UFO some special way for a new tool is not how it’s supposed to work.

In any case, my issue has nothing to do with exporting UFOs from FontLab. And I do have RoboFab (as well as FontTools, etc.) installed successfully in Lion.

1 Like

Mark, Thanks for clarifying.

I quite agree that the point of UFO is the ability to use multiple software apps to edit your work as you see fit, regardless of platform/operating system and hopefully, date of creation. I quite agree that we should not need to go back to FontLab every time we want to use Glyphs, RoboFont, or anything else. At the moment, I have 8 years worth of work all in .vfb files so I really need to have interoperability. Part of that means FontLab needs to fully support UFO seamlessly. Part of that means every application developer needs to stay on course with how they interpret and output UFO. Obviously, operating systems have to play nice and not ignore the requirements of UFO. I don’t mean just Lion and Apple. Every Microsoft system upgrade has the potential for breaking UFO marriage vows.
That is why I find my testing frustrating. If I need to go back to FLS 5.04 to be able to generate a UFO that Lion likes, that is not acceptable. If a Glyphs generated UFO cannot be opened by glyphs in the same Lion OS that created it, that is unacceptable. What baffles me is that some UFO savvy apps (RoboFont and Metrics Machine, etc) have no problem in that same Lion System, why do DTL and Glyphs not work? I will reiterate, "I have NO IDEA who is not playing nicely with others and whois just stuck in the crossfire between others. I don’t want ANYONE to feel blamed by me. I am just posting what I see from various attempts so that the people who code the various softwares have a view of what happens so they can honestly evaluate what needs to be done either on their own or in consort with all players. Hopefully, it is some simple code adjustment and all this will go away. I am not a programmer by any stretch so I can CLEARLY be wrong in my conclusions. Therefore, I attempt to avoid conclusions and just post observations that might be helpful in solving the riddle.
I would like to see every application developer succeed and flourish. That is why I have purchased from all of them. Competition is healthy, yes, but cooperative problem solving among all is the best way for everyone to “win” without hurting any of the competing products.

The problem with the import of .ufo in Glyph will be fixed soon.

In the meantime you can use a script that exports .glyphs files directly from within FL. It works similar to the .ufo export script. You can download it from my github page. Look for the file “Glyphs” and place it in
/Users/[your user folder]/Library/Application Support/Glyphs/Scripts

The export script has one big advantage that it can export multiple master files.


Cool, thanks! And thanks for the tip about the .glyphs export script. That looks very useful.

I’m having the same problem, is there any news on the fix?

@exljbris: What version of Glyphs do you have. And could you send me you .ufo for testing?