Can't make Kernkraft plug-in work

Hello there,
So this is a silly situation but I am trying to make kernkraft work on glyphs [ Version 2.4.1 (983) ]. I used it last week but now it doesn’t work anymore.
After seeing it doesn’t work I erased it from the script folder, I tried to reinstall vanilla from preferences>install modules but no pop up window showed up after writing the password ( So I assume it’s fine). Then I both clicked on the kernkraft plug in file and I pasted it in the script folder.
When I go to the plug in manager it says it’s installed (I also tried to uninstall and re-install it from there).It’s shown in the script appendix but when you click on it nothing happens, no pop up window with the tool. I’ve restarted the computer and rebooted glyphs several times.
I know the plug in is installed because when I click on the plug in file again I get:

Are you sure you want to install the plugin:

The plugin will be placed in /Users/usuari/Library/Application Support/Glyphs/Plugins.

The plugin:
is already installed.

Do you want to override it?

And I have replaced it. Any idea on how to make it work?
In this situation I’m wondering if the problem is vanilla, glyphs or the plug-in.
Thank you for your help!

Thanks for reaching out. You already remarked this at Github. We’re trying to figure out what’s going on there. So this thread here can be removed @GeorgSeifert :slight_smile:

Thank you!
I posted it on both because I wasn’t sure what was the reason it’s not working.