Can't save/open Glyphs3 - Glyphs2

Hi everyone!

I was working in a project where in Glyphs2, I decided to open that file in Glyphs3 —just for take a look— And now, I can’t to save it from Gyphs3 to Glyphs2.

I found couple of Topics before in the Forum, but, I still considering those parameters, —means, go to Font Info> Other> Switch from Version 3 to Version2—, but it still doesn’t work. And then, just appear this.

Screen Shot 2023-02-27 at 11.47.36 AM

I haven’t set any Custom Parameter yet, so, didn’t get it.

PLEASE, any piece of advice?

I’m attaching another picture, just in case!

Screen Shot 2023-02-27 at 5.09.58 PM

You seem to have set the Font.previewRemoveOverlap. You need to set this to True to be able to write the file as format 2.

Thank you for your reply Georg

I don’t remember configuring anything, is there a button to disable that option you mention?

I haven’t found anything on this topic in the Glyphs Forum and Manual.

Open up the Macro window and type
Font.previewRemoveOverlap = True, then run that.

1 Like

Thank you very much Sebastian, I really appreciate it.

But why did that happen? I mean, I hadn’t activated anything about it. :man_shrugging:

Can you open the original v2 .glyphs file again and see if you can just save it again?

Yep, it’s working now, but, as I asked Sebastian, I don’t know why these things happen.