Cap height line does not show up


In certain files (can’t specify which ones exactly), the cap height line does not show up even though it is set in the font into. Any idea why is is happening? Thanks!

Screenshot 2021-04-12 at 13.23.56

Why do you need the cap hight in a lowercase glyph?

Because I have the ascenders aligned to the height of uppercase.

So you uppercase are higher than the ascenders?
I recommend to use the “correct” values and add custom parameters to control the vertical metrics.

No, uppercase are the same height as ascenders. And for such a case, it make sense to use cap height line for aligning the the ascenders. Or are you suggesting to set the default values of real ascenders and descender regardless UPM and add custom parameters to control the values separately for export?

I recommend to set the Metrics values to the actual measurements in the glyphs. And if that doesn’t produce desired line spacing, add custom parameters

1 Like

I found a workaround for needing to show the Cap height in the lowercase letters, and the X-height in the Capitals, as I want to see both lines displayed in both sets.

  • In Info > Masters > Metrics, make a note of the values for Cap Height and X-height.
  • Then delete the defaults (click – to the right).
  • Click the + and add a new Undefined line.
  • Click Undefined tag and set the Metrics Type to “Other” and give it a Custom Name of “Cap Height” (don’t pick Cap Height from the popup). Click OK, and enter the settings for Cap Height.
  • Then repeat this for X-height, being sure to select Other and naming it “X-height”.

If there’s a better solution, please let me know as I’m a newbie.