Change App language?

Is it possible to change the program language? I have German, probably taken from the OS, would like the app in English. Can I change the language?

There is a setting in Preferences > User Settings.

1 Like

Disable Localization?
It’s checked, but it does (after restart) not work. The App language is still the same as the OS.

You also need to add English to the available languages in System Preferences > Language & Region (System Einstellungen > Sprache & Region). Set it that English is second after German. And don’t restart the mac when you are asked.

It worked, thanks!

1 Like

Now I have a new Mac with High Sierra. I did the settings like on my Mac with El Capitan, 2nd English U.K., in Glyphs second language is not offered. Is there anything else that needs to be done to get English?
I can’t work with the German language because I can’t find any function or anything else, all documents, information, forums,… are English. So it would be easier if I could rearrange it.

Glyphs > Preferences > User > Disable Localisation

And you need to have “English” in the list of supported languages in System Preferences. Just add it that it is at second place.

I’ve done it now, thanks again!

Hi! I’ve tried what you mention but it doesn’t work. I have the interface in English and I want to change it to Spanish. My version is 2.6.2 and MacOs 10.14.6

In system preferences > languages I have English as first option and Spanish as second option. In Glyphs I have checked the disable localization option and restart it several times.

Someone has any idea?

You must have Spanish as first language, and English listed somewhere below. And don’t disable localization, otherwise you lock it to English.

If you need your system to be in English and but Glyphs to be in Spanish, you can run this script in the Macro Window.

Glyphs.defaults["AppleLanguages"] = ["es"]
1 Like

I’ll add that to the Hidden Settings Script.

1 Like

Perfect! Thank you very much!

I’m having a similar problem to the user who wanted Glyphs to appear in Spanish on an English system. I have Glyphs set to French via command-line tools, but when I open preferences it auto-selects ‘Disable Localisation’ and relaunches itself in English. The app stays in French if I don’t open Preferences. It reopens in English even if I deselect Disable Localisation. How do I make the app stop auto-selecting Disable Localisation? My computer’s language settings are English (UK), French (France), German. I’m using Catalina.

When you set the language with the script, just ignore the checkbox in Preferences.

I have the same problem here, I would like to change the app language to english but I have Glyphs mini 2, and I do not have the settings mentioned above. Is it possible to change the app language in the mini version?

Mini does not have the setting. It always follows the system language. You would need to change the system language prior to opening the app.

I believe there are also third-party tools that allow setting of app languages.

1 Like

I thought so, but for the moment I will have to work with system language of my computer but this is ok for now. Thanks for clarifying!

It works with macOS own resources:
Change it in the System Preferences (Language & Region > Apps) if Glyphs Mini contains the desired language and the second language is active in your macOS. It’s very simple, add your App by ‘+’, that’s it.

1 Like