Change order of Glyphs?

Hello. I’m trying to reorder my characters in my glyphs palatte but unable to figure out how to do that. For example: when I export my font and examine the font’s glyphs in Adobe Illustrator I would like my capital letters to all be next to each other “A B C D…” although right now Glyphs is outputting the order as “A A(acute) A(circumflex) A(grave)…” etc. How do I reorder these so that these secondary accent characters are lower in the order?

Reason being, I am building a face with alternate “A’s” so I would like all the A characters to all be next to each other in any external application’s character palate of my font.

Currently there is no easy way of influencing the glyph order.

I do not fully understand what you like to accomplish. First you say that you like to have the base glyphs separated from the accented letters and then you say that you like to have them together.

And what do you mean with secondary accent characters?

Below is an image example of what I am asking about. In the top half of the image is an other font’s glyphs pallet (in Adobe Illustrator), notice how alternate “A” and “C” characters are right next to the standard “A” glyph.

The bottom half of the image is my font’s glyph pallet (also in Adobe Illustrator.) You can see that not only are accented letters following with the base letters but my alternate glyphs (I have alternates for both “L” and “J”) are not at all in proximity to the base “L” or “J” glyph. (They are only found if a user scrolls to the bottom of the glyphs pallet.)

I would like to

  • group alternate characters next to the base character (“M” | M2")
  • I would like accented letters to be removed and moved so that base characters are grouped in closer proximity (“M” | “M2” | “N” | “O” NOT “M” | “M2” | “N” | “N-tilde” | “O” etc.)

Does that make sense?

The reordering is not possible at the moment.

I will think of some solution.

I had this same problem when importing a font and it was all out of order. Just go to the main info window (top left “i” button) and under “Font” there should be something about glyph order in the custom parameter field. Just delete it and the whole thing should re-order itself.


  1. Your glyph names are not okay. Instead of M2, use M.ss01. It’s a good idea to stick to the conventions. Glyphs can then produce the corresponding OT features automatically for you.

  2. Possible solution A: Use a custom list filter if you want that order in the font tab. Gear icon at the bottom left. (I personally use a smart filter for what you call base glyohs: script is latin, count of paths greater than 0, first master has no components, glyph name does not contain “.”)

  3. Possible solution B: Use a sample string if you want that order in an edit tab. Advantage: you can even use returns and separate glyph groups into lines.

Isn’t still a way to make the glyphs to appear in Adobe’s Glyphs Palette in a particular order? No matter how I order my ornaments in Glyphs, they always show up differently in Adobe’s Glyphs Palette.


On the Glyph panel in InDesign, select Sorting option and switch from Unicode to CID/GID. Your glyphs would follow the glyph order of the font. Unfortunately Unicode is the default option in InDesign.

The Glyph Palette is already set on ‘by CID/GID’.

You need the glyphOrder parameter, see the ‘Intermediate’ solution in this tutorial:

I also already made a custom parameter with the right order and it didn’t affect the order of the ornaments at the end of the encoding.

Where do you check? In OTMaster? I just checked and the glyphOrder parameter reorders glyphs in the OTF as expected. Perhaps there is no way to control the order in the glyph window through the font itself.

Different idea: ornaments should be letter variants, and implemented as bullet substitutions. I.e., rename them to A.ornm, B.ornm, C.ornm, etc. This way you can also control the order. Glyphs can automate the ornm feature for you.

InDesign, Illustrator, Fontlab

I just tried and it worked like expected.
What version of Indesign do you have?
Do you use the Adobe fonts folder?