Changing Hot Keys and Shortcuts?

Sorry to bother but I have an odd question. It has to do with the Home and End keys. I know that on a desktop and a Mac keyboard, I can strike the Home/End and toggle left and right through my glyphs. I recently purchased a Logitech Craft keyboard ( As it is, in general, I love the keyboard and the potential of it… however… I purchased this keyboard not knowing that the Home and End keys are basically dead. For some stupid reason they have not configured those to work on as a Mac keyboard. Which means I cannot toggle. I have tried Function and arrows to see if might emulate a laptop keyboard, but it doesn’t. I suspect, eventually, this will be corrected, but I’d really like to use this keyboard. Is there a way in Glyphs to change that shortcut to something else/some other key.

I’ve noted in the handbook that I can change tool shortcuts, but I believe that is for single-stroke changes and not two-stroke… for example, I was considering changing this Left/Right toggle to Cmd-[ / Cmd-], respectively.

Any ideas or this just a limitation and I need to return my keyboard :wink: (Seriously, I’ll return it over something like this… I can’t have my workflow screwed with)

Any guidance would be appreciated.

I would use Ukelele to fix the keyboard layout for this keyboard, or try one of the alternate keyboard layouts.

So that’s a ‘no’ that there is a way to substitute/change shortcuts with other key combinations?

Ukelele is an inventive fix, but since the Logitech Keyboard layout specifically addresses End and Home as Cmd - ← and Cmd - →, respectively, I am unable to assign a dead key and reassign with :arrow_upper_left:︎ and :arrow_lower_right:︎… which is why I asked if I could just change it in Glyphs until Logitech corrects this.

Huh? Why a dead key?

Actually, I tried rearranging the Home and End keys in my Ukelele install, and Ukelele warned me:

Yeah… that’s the oddity… it’s not Ukelele, it’s the Logitech Craft keyboard assignment for those keys… I cannot overwrite it and then reassign them. I cannot toggle from one glyph to the next using this keyboard and I cannot reassign/activate the keys on the keyboard.

But you can. You either just ignore the warning and try it in Ukelele (just drag the home and end keys to another position), or you try one of the suggestions in this warning dialog.

Not with this keyboard… I have tried repeatedly. Besides, this continues to skip the issue and question of being able to customize shortcuts in Glyphs.

As you mentioned reading in the Handbook, use the System Preferences, go to Keyboard > Shortcuts > App Shortcuts > Glyphs and add a new shortcut using the + button. The menu names for previous and next glyph are Show Previous Glyph and Show Next Glyph. Then, in the Keyboard Shortcut field, press the keys you want to map to, e.g., your mentioned Command-[ and Command-].

Even though you’re pressing multiple keys down, that Command-[ counts as a single entity, as would Shift-Control-Option-Command-someletterkey.

Hope that helps.


This worked beautifully… I will admit to not being aware of the fact that was an option within Apples System Prefs… I am used to making this modification within the Apps prefs and not here… love it. One nice result of this… I was able to map the dial on the Craft keyboard to this now… using the modified shortcut, I can now turn the dial to move back and forth through glyphs. Thanks Jeff!

1 Like

You have a dial on your keyboard?

Yes, I do. It’s surprisingly welcomed change to the typical keyboard. I referenced it earlier in this thread, but it is the Logitech Craft keyboard


What is the name for Make Node First? I would like to apply a shortcut for that also. I’m doing that process of adding the shortcut on the system preferences, but it is not working.

You can only apply shortcuts to menu items in the main menu. The “Make Node First” is in a context menu.

You could add a script that does the change and because it ends up in the Script Menu, you can add a shortcut to it.

1 Like