Characters not appearing in Apple Preview

I am working on a textured font and some of the characters are not showing up in the Apple Preview app. Any ideas on why this might be? The characters do have a lot of points, but not more than another textured font I tested. (Thirsty Rough from YDS).
The “A” characters are labeled .ss03-ss07. I did update the features in font info.

Just to make sure what we are seeing, are you exporting the font sample from Illustrator as PDF and opening it in Preview?

No, I am just opening the .ai file in preview. (The bottom screenshot is what appears.)

Did you read this?

I did not read that (bad citizen) I’ll follow those suggestions and let you know. Thanks!

And make sure you don’t have a font cache problem:

FYI, I followed the instructions and am still only able to save the font as TTF. The characters do appear in Preview, its just a bit slow. Is there a filter to simplify the number of nodes without destroying the curved segments?

That means that you have way to many small paths or small curve segments. Consider using the DeleteSmallPaths plug-in from the Plugin Manager. Or the Roughen filter, but with horizontal=0, vertical=0, and experiment with different segment lengths.

So, I’ve disabled subroutines and exported as TTF. But when you zoom into the characters in Illustrator, the shapes have been completely destroyed and its adding strange extra shapes to the other outlines…
Any suggestions??

Is there really no way to keep the curved paths??

What version of Glyphs do you have? Can you send me the file?

I have 2.3
Where should I send the files??

Please try 2.4 first. I fixed some TTF problems.

ok, i will do that. I’ve sent the files to info@

This is 2.4 - file saved as TTF.

This is from GlyphsApp… Looks perfect

This is from Illustrator (solid black) and glyphs app. Still adding odd shapes to some characters. In this font, it is the G and the O

You have quite a few problematic paths.

  1. extremely short curve segments: consider replacing them with straight lines
  2. closed paths with only two on-curve points: try adding a third point or add extremes.
  3. many curve segments: consider using the Roughen filter as described in the Complex Paths tutorials.

Disabling subroutines only has an effect for CFF (.otf) fonts, it does not matter for TTFs.

We did try Roughen, and we don’t really like the effect. But besides that, when we try to export that file as an OTF it gives me an error message… Do you think there is no way to keep the curved segments?

Try disabling GPU Preview on Illustrator (View > Preview on CPU). This may not be the issue here, but I have seen some outline glitches that were traced back to hardware acceleration on recent versions of Illustrator.