Colour Font Display Error on Google Chrome/Adobe Illustrator

Hey there.
I am developing a font that contains some coloured emoji/symbols. It works and looks nice on Glyphs 3 and Pages; the font can change to any colour but designated emoji/symbols.

↑ Works on Glyphs 3

↑ Works on Pages, the emoji remains in designated colour.

However, I found it is not working on Adobe Illustrator and Google Chrome (as a customised font).

Problem 1:
In Illustrator, the emoji became monochromic and able to change the colour.

Problem 2:
I had changed the customised font on Google Chrome, which can replace other fonts of any website. However, all characters are in black; instead of the “Forced Bold” characters. It works if I export the font without the coloured emojis.

↑ All characters were in black…

↑ It works if I export the font without colour emoji.

I am wondering what the problem is. Am I using the wrong method on the coloured emoji part? Or just the issue of Google Chrome?


  • Glyphs 3.0.4 (3108)
  • macOS Monterey 12.0.1


What type of Color font do you use?

I used the “Color Palettes” to create the color font.

What is your instance settings look like?

AFAIK, AI does not support COLR/CPAL fonts. But it does support SVG. You can put both variants into the same font though if you use the appropriate custom parameters. See the colorfont tutorials.

1 Like

This is the instance of the font, but I did not put any custom parameters on it.

I tried to use “Color Layers to SVG” in the instance settings. The emojis stay with designated colours in AI. However, other non-colour characters were stuck with the black; which I can’t change the text colour.

Any suggestions? Thanks!

Can you send me the .glyphs and the .otf file?

Thanks Georg! Just sent it through the message. :slight_smile:

I tried the fonts and they seem to work fine for me.

This is the way how I change the customise font of Google Chrome (Settings → Appearance → Customise Font). The preview were in black as well.

Prison Gothic Pro with colour emoji, Lite don’t.

Can you try to test the font in font tester like If you can change the color there, the font is fine and the issue is with Chrome.

Thanks Georg! Just tested the font, seems that’s the issue of Google Chrome.