Coloured fonts for general use?

I’ve been searching for support of coloured fonts on common apps, and it seems they are unsupported. For example, on a Mac with Pages or TextEdit, or something like Microsoft Word, or Libre?

I searched this forum also and found a post, back from 2017, which seemed to give this conclusion - that Glyphs can make them but that these apps don’t support them. Is that still true now? Or have things been updated since? I’d love to be able to make a font with colours!

CPAL/COLR fonts are best supported on browsers. They also work on Mac apps and in Word.

I’m purely aiming for offline documents.

So I can create a font, for example with A B and C in blue, and D E F in red, and if I use it in Word, Pages and TextEdit, typing ‘ABCDEF’ will make A B and C automatically appear in blue, D E F in red?


Just tested again in current versions of Mac Word, TextEdit and Pages, and can confirm: CPAL/COLR glyphs are displayed in their colors in all of these apps. But don’t take my word for it, feel free to try for yourself.

Here is how to make a CPAL/COLR font:

It also contains a link to a page that tracks app compatibility.

1 Like

Just of interest, would they work in apps like Terminal or Atom or text editors? has the same renderer. I have seen sbix emojis in Terminal.

1 Like

Thanks @GeorgSeifert and @mekkablue for your advice about colour fonts. I had a lot to work on but now I’m bacl to fonts and waiting on an anchor issue, I’ve startd with colour. And it works great! I’ve got ligatures using two colours now. And works fine in Pages on Mac!

However, it doesn’t seem to work with non-ligatures. Like the ligatures, they have two parts, one of each colour. I have done exactly the same with the ligatures and non-ligatures and both look great wihtin Glyphs. But when exporting, if the non-ligatures are included for export, they make the font not export. I get this message for the letter i for example:

It’s referring to the two items within that glyph. One is in layer 0, the other is in layer 1. Here’s the glyph info:

The ligatures worked fine so I do not understand why this is happening. Also the ligatures even worked if I kept both elements in the Color 1 layer and one of them in the Color 0 layer (which would therefore block out that one in Colour 1 layer anyway, giving the same result).

Help much appreciated!

What version of Glyphs do you have? Can you try the latest cutting edge version?

Can you send me the file?

1 Like

Version 2.6.3 (1271)

Sure I’ll try tomorrow!

Just sent it now. Thanks so much George!

Hi Georg,
So I updated Glyphs and this problem is fixed! Thank you!

By the way, I updated the app by going to updates within the app itself. Just to let you know, the update installed the new version of the app in the folder I had been currently using for saving files. Not in the application folder. No big deal, I simply moved it to the applications folder - though then my actual files would not open, showed an error message. But then starting the app, and then clicking, did work. Presumably it will work fine from now on. But just letting you know.

So now my only remaining hurdle (for now) is working out how to predictably use 4 functional anchors for ligature glyphs to be able to take 4 kinds of marks (as mentioned in the message I sent you). Once that is done I should have an awesome new font!

And for anyone else reading this wondering if Glyphs is good for making color fonts (or fonts in general) - it’s awesome! Many tricks to learn but this is a really great app. Doesn’t take long to learn how to make awesome fonts and make all kinds of specialised behaviours.

Oh one more question… so my first attempt at making the 2 coloured glyphs I mentioned above, was to make one special glyph have a chosen colour. And there are other glyphs (no colour, i.e. default black with no colour layers) which use that as a component. I thought because the component was coloured, it would maintain its colour when added to other glyphs. But this didn’t work. I had to manually add the colour layer and do all the steps to make that component coloured (adding two colour layers, making the component the wished for colour, and making the rest ‘black’).

No big deal if that’s what we need to do. But is there a shortcut? In such a case where we want that component to always be the chosen colour?

There is no shortcut. The components in the default (black) layer link to the shape in the other default layer.

1 Like

OK cool, thanks George!