Combining Glyph Component Glyphs not interpolating between 2 of my 4 masters

I’m having an issue (can’t find answer in the forum yet) with interpolation on all of my component glyphs (like ugave, etc.).

I created 2 masters (regular and extra bold) and then added a third master later (extra light). After creating all my standard A-Z, a-z characters and combining marks, I selected all my empty European characters and clicked on “Make Component Glyph” like I normally do. But for some reason it won’t interpolate my middle instance between my 2 masters (extra light and regular). My instances between my Regular and Extra Bold masters work just fine on all, and my base characters and combining marks interpolate just fine too. So I’m baffled.

Have you read the multiple master tutorials? There is one abut compatibility.

I have. And the strange thing is that the base characters all have the right number of anchor points, consistent path direction and order. There is no error on the base characters but when I use the “Make Componenent Glyphs”, it’s just grabbing those characters that work on their own, but for some reason then I have the red “incompatible” bar showing and it’s not interpolating fully.

Hey @GeorgSeifert ,

I tried just deleting the combining characters with errors, then adding them fresh and that fixed it! Must just be some sort of glitch?

Anyhow, thank you so much for the help as always. So appreciate this helpful forum and the quickness of replies. :slight_smile:


You might had different version of the accents used as components. E.g. the grave vs gravecomb. In Glyphs 3, View > Show Master Compatibility would have shown that.

Very possible - I’m on Glyphs 2. Thanks, Georg!