Compatibility error when exporting variable font

I’m working on a typeface with 2 masters, when I try to export a variable version it gives me this error:
“These glyphs are not compatible: fehDotless-ar.medi, heh-ar.medi.ss01, hehDoachashmee-ar.fina, hehDoachashmee-ar.medi, allah-ar
Probably the TrueType conversion failed”

I exported both otf and ttf formats successfully, and all glyphs look compatible.
I also activated Enforce Compatibility Check parameter but no change.
I’m using Glyphs 3.0.4

Can you post a screenshot of the paths of one of the glyphs? I assume there is something that cannot be converted into OTVAR curves. E.g. an outside overlap, a stroke, or a mask.

Up is one of the glyphs with this problem.

And this is the component used in the glyph:

Can you please try the latest cutting edge version? (You can activate cutting edge versions in Preferences > Updates)


Newest version is 3.0.5. You have to go to preferences and check cutting edge versions to be able to update to that, like GeorgSeifert said :point_up_2:t2:

Did that but, still have the same error:

Can you send me the .glyphs file?


You somehow added intermediate coordinates to the Bold master:
Screen Shot 2022-05-13 at 21.22.27
Use this script in the macro window to remove it (with the problematic layer active):

1 Like

Thank you, indeed that was the problem.

I’m having the same issue but I’m using intermediate layers + cap components.
Are cap components + special layers supported?

Cap components can produce incompatible outlines in some circumstances. Can you send me the file that I can have a look?


I found the problem and fixed it.