Component alignment with manual spacing?

Hi there!
I would love to have all the components aligned but set the spacing manually. Is there a way to doing this? In cyrillic is pretty often to get problems like this:

This way I’m happy with the spacing, but components got unsynced

When I activate automatic alignment the components are good buth the width of the glyphs is automatically set as л, which is really a problem :expressionless:

My workflow is really stupid for the moment:

  • Activate alignment (for align all the components)
  • Deactivate alignment
  • Set spacing again (or HT Letterspacer)

is there a smart way to do that?
Thanks!

j.

You could add =+20 in the RSB for example. This way you would add 20 units automatically. If you type ==+20, it will only affect the current master.

1 Like

Thanks Jacques! Is a bit tricky but it works

Or use #exit and #entry anchors. It will inherit the LSB from the first, and the RSB from the second component.

2 Likes

Thanks, where do I have to add them?

I just added Replicate spacing with aligned components script for dealing with this:

You add the #exit anchor in the ш and the #entry in a separate _tooth glyph, then you build the щ with components of ш and the _tooth. You can reuse the tooth in a similar fashion in other glyphs. Hint: Keep both anchors on the baseline.

1 Like

I have used it for making swashes in a current font (Glyphs 3 3078).
When using this technique along with sync metrics plugin, the anchors keep rearranging itself and moving to the left. It would be nice if stayed still.

I tend to think that the plug-in will need an update. Because syncing sidebearings should not have an effect on cursive attachment.

do you have anchors together with components?


in the components I only have #exit #entry anchors. But in the finished glyph (T.swsh) I have the three anchors that are meant to be there for diacritics - top, center, bottom. These are the ones moving with metrics sync. cmd+shift+opt+M yields the same issue from what I just tested.

Can you show the info box for that glyph?

Having components and anchors is always tricky.

And there is a reason that I don’t enable automatic metrics syncing because it can create issues like this and messes up the undo.

here you go…

So in this case, the plugin shouldn’t do anything as this glyph is auto aligned. Can you disable the auto alignment for those two components and check if there is a (hidden) metrics key?

1 Like

There sure is. RSB was T. Since some components are set up with metrics keys, should an Auto Aligned setup like this ignore/delete these “ghost” keys?

The sync metrics plugin needs to ignore the keys, for sure.