'Component Mover' script does not work

hello. I am not familiar with English, so please understand that I will have to use a translator.
I am using the mekkablue script, but the component mover function does not work.
All other functions work normally.
Only the component mover doesn’t pop up any window when clicked.

I am using Glyphs 3 and it is version 3.1.2.
The macro panel appears as follows:

Traceback (most recent call last):
File “Component Mover.py”, line 231
File “Component Mover.py”, line 34, in init
autosaveName=self.domain(“mainwindow”) # stores last window position and size
AttributeError: ‘ComponentMover’ object has no attribute ‘domain’

I don’t know how to solve this problem because I lack relevant knowledge.

Thank you for reporting. Will have a look

I fixed it already.

I reinstalled the script.
Something has changed but it still doesn’t work.
Now you should see something like this in the macro panel:

Traceback (most recent call last):
File “Component Mover.py”, line 232
File “Component Mover.py”, line 44, in init
self.w.changeAttributeUpdate = vanilla.SquareButton((-inset - 20, linePos, -inset, 18), “↺”, sizeStyle=‘small’, callback=self.update)
AttributeError: ‘ComponentMover’ object has no attribute ‘update’. Did you mean: ‘updateUI’?

What is the problem?

I’ll ping you on DM.

Update: I think I fixed it. Plus there is a new option. :slight_smile:


It’s finally working properly.
Thank you.

1 Like