Component scaling with arrow keys broken


If I remember correctly, I reported this issue for Glyphs 2 already a long time ago, but I ran into it on Glyphs 3 today, too :slightly_smiling_face:
When scaling a component by percentage (via the fields in the Info panel), it is impossible to use the arrow keys consecutively. What I mean: If I use arrow up to go from 100 to 101 percent, the cursor jumps out of the text field and I have to click it again to continue. The cycle repeats from there.

The difference (thankfully) to the bug in Glyphs 2 is that pressing the arrow keys again does not affect the (seemingly) selected portion, so no more accidental nudging of paths due to this bug, at least.

If anybody has any clue as to why this is happening, or what I am missing, please let me know! Thanks :slightly_smiling_face:

P.S.: There appears to be some odd behaviour with tabbing in those fields, too. If you edit the value in one field and then tab, it jumps to the next field, but exits after a split second. If you donโ€™t edit the value in the field and tab, it jumps to the next field and stays.

This works fine for me. Can you make a screencast of what you are doing?

Sure. Whatโ€™s the best practice for sharing video material on here? Hope this works

Explanation: I click into the percentage box and use (shift) arrow-up. The scaling applies, but the box is immediately quit.

What version of Glyphs do you have?


Right, I was testing the wrong branch. So I fixed it and it will show up eventually.

1 Like

Thank you!