Component sidebearings in Variable fonts change

test

#1

Hello,

I ran into some strange behaviour of the sidebarings of the components of a variable font when I tested it. I couldn’t find it somewhere else on here.
In the glyphs file all the sidebarings are fine.
I’m working in the latest Glyphs beta version and I’m testing in Chrome. No Adobe CC or High Sierra at hand right now.

Both on the top are in the browser and the last one is how it looks in Glyphs.

Oh, and since I’m here: Cmd z doesn’t always work in the latest beta. Don’t get me wrong. I’m not saying that it’s not fun. It’s just that after a while it gets a bit tedious.
In the beta before this one it didn’t seem to work after actions like “reconnect points”. But with the latest I’m not able to recreate any action where it doesn’t work. Sorry to be that vague.

Thanks in advance!


#2

That is a bug in MacOS. CoreText is applying the left sidebearing of the origin master to the interpolated component. It doesn’t do that for outlines with paths.


#3

Hi @GeorgSeifert, thanks for pointing out where the issue is coming from! I believe I’m experiencing the same problem.

Do you know if a bug report has already been filed with Apple, or would it help for another to be filed?

I’ve tried to search for an existing report, but it appears that the Apple filing system may only show the reports you have personally filed. I know this isn’t your bug, but if you have any idea of the status of this or if you have any suggestions for how I might find the status, that would be terrific.


#4

I did file a bug already. But filing another one is usually a good idea. Apple changed the ‘privacy’ setting and now you can’t see the reports from other people any more.


#5

Thanks so much for the quick reply! Shoot, that’s a frustrating policy from Apple.

For what it’s worth, I’m having better luck with the VFs I generate directly from Glyphs than what I was generating through FontMake. So, it’s possible that Apple has addressed the CoreText bug, and that my problem may be either from me or from FontMake. Will dig further.


#6

I tried a few days ago and the bug is still in Mojave.