Composite glyphs with misaligned components

I have my base glyphs with anchors, e.g. A with anchor top.
I have my marks with correspondent anchors, e.g. acute with _top. As soon as I click on the anchor in the base glyph I have the ‘mark cloud’ to show me where the marks are gonna be placed. So far, so good.
But when I create the composite glyphs, e.g. Aacute, the mark is not positioned as it was supposed to be. I tried to generate Aacute from the left menu groups, or by top menu Font>Add Glyphs… the result is the same.
Any idea why this happens?

Can you check what base glyphs the acute component points to. It might be the (or acute.cap) and that might have no anchor.

Or do you have disabled automatic alignment in Font Info > Other Settings.

I had disabled the automatic alignment. Thanks Georg.
Regarding the Disable automatic alignment option: a possible use of this option is when I import new metrics and I want to avoid that a change in the sidebearings of a mark is going to affect the position of the mark in the composite glyph that already exists. Is that correct? If not, what are possible situations when I would need to use this option?

The option is there if you open a fonts that has manually positioned accents and potentially some missplaced anchors (like all fonts that come from Fontlab).

Changing sidebearings do not disrupt relationship between anchors and outlines. They all move together, so don’t worry.

Disabling component is useful when you make glyphs purely made from components whose position you want to adjust. In Latin, most common case is probably ldot, Ldot, napostrophe (don’t question why I am making these in the first place). In non-Latin it happens quite a lot.

Hi Toshe, good point, that is what I’m facing right now.
For example, if I have napostrophe made of two components positioned manually (referring to n and commaccent).
Let’s say that I’m happy with my manual positioning.
As soon as I change the sidebearings of any one of the two glyphs the components are referring to (n or commaccent), the napostrophe is messed up. I tried disabling automatic alignment, but it doesn’t work. Where am I missing something?

napostrophe: Just kern quoteright-n properly, the automatically aligned components will follow.

BTW napostrophe is not in use in Afrikaans, but quoteright-n is (or quotesingle-n by non-typographers). It is officially deprecated, but remains in Unicode for backwards compatibility with some outdated encoding from the late 70s/early eighties:

I use automatic alignment for them as well, usually with a double underscore component (__periodcentered), which adds its width to the compound glyph.