Composites during export form FontLab

Dear Georg,

we’re up with the development of a pretty big family and, since I decided to switch to Glyphs in the middle of the process (I know it’s not a great idea), I’m converting to your app also the almost finished styles from FL.

Now, everything seems to work fine except composites. In fact the glyphs file correctly keeps the composites, but misplacing them. Fractions or accented smallcaps, for example, are all messed up. I tried to also get rid of MM from the FL file but it didn’t worked.

any clue?

thank you

The misplacement of the composites is the automatic alignment of the components kicking in. This has nothing do to with MM.

There are a few things you can do.

  1. refine the anchor positions in the base letters and accents. This will help with the messed up smallcaps.
  2. the fractions are probably build from “one.dnom” (shifted up) “fraction” and “two.dnom”. Open a fraction glyph and select “Layer > Make Component Glyph”. This will change the components to “one.numr”, “fraction”, “two.dnom”. To fit them together, adjust the spacing of the fraction and apply kerning to the “one.numr” “fraction” pair.
  3. this dirty way is to add one node to each glyph in FLS. This will stop Glyphs from realigning the components. The node is ignored on export.

Does this help?

ok Georg. Let me check and I’ll get back to you.

thank you!