Connected Nodes

Screenshot 2023-02-25 at 14.55.55


How do I get rid of these connected nodes?

Path > Other > Convert to Cubic.

Why are you working with an imported TTF?

Battery ran out on my laptop and lost most of my progress, had a saved version of the ttf, is there a way to convert it?

How do you mean you lost your progress? Why are you working from an imported TTF file in the first place? If you are modifying an existing font, you should be able to find the original source files on github (as long as you’re modifying an open-source font, otherwise the question of legality arises). What font are you working from? Working from the proper source files is always more desirable, because a lot of stuff gets broken/lost when importing a font file into a font editor to work with it.

You can select all glyphs and run Path > Other > Convert to Cubic. The outlines you are seeing are quadratic TrueType outlines. You want to work with cubic (PostScript) outlines.

Ah I see, so what happened was I was originally working on the glyphs file. After completing the first version, I saved a ttf version of the font, however, I didn’t save my progress on the glyphs file, so i started working on the typeface again on the ttf file i opened on glpyhs.

Is there a better way to do this?

Ouch, that hurts. Depending on your workflow (and intended project scale), I highly recommend looking into version control (git, preferably). Regularly commiting your changes will create a detailed version history of your project, always neatly backed up. Use the glyphspackage file format when saving your glyphs file. This format facilitates version control.

For your current case, I can’t think of a better solution – Glyphs does save an (Autosave).glyphs file upon almost every change you make to your file. It will be saved to the sam location as your working glyphs file, although I don’t know where it would be saved before you have even saved your file for the first time. Did you save a version at some point?

I didn’t sadly, how will this affect the font?

The outlines are essentially the same, but you will probably need to re-check your vertical metrics settings, as well as your general font metadata in Font Info (Font, Masters, Exports…). Maybe there is an autosave file somewhere, but I wouldn’t know where that is saved (somebody else will have to answer that).

1 Like

First, I would recommend to regular save your file. Glyphs should save the file every 10 seconds. Have a look for a file that has the same file name as your .glyphs file but a “(autosave)” appended.

1 Like