Convert png file to svg file in batch

I successfully exported the otf file.
There are also svg layers in the file.
But I edit that oft file glyphs is very laggy (almost impossible to use)

Then I also have an automatically generated svg image file.
But I use chrome to open is blank
The finder preview is a bit black on it (like this


maybe characters are truncated on top. Is this normal?

If normal
I am going to open a new glyphs file batch and put the generated svg into glyphs just like I put png?

I just succeeded.
But I just opened a new file and re-made it and got into an unlimited export.
Not like the successful one spent 10 seconds

forget it

Do not open the .otf file. Keep working on the original .glyphs file.

The .svg data in the font has to be prepared to work in the font. When you open a .svg in Illustrator, you will see that all the content is above the page.

Ok, I don’t know what to do next?
I added the svg layer to put the generated svg file into it (I don’t know if this is right)
But the svg display is blank
what should I do

Sounds like the SVG is prepared wrongly. Have you verified the SVGs from AI? You can see in the Finder preview that all the content is placed too high.

In the case of these b&w images, it may make more sense to trace them and make a normal font, not an SVG font. You can (1) do it in Illustrator and copy and paste into Glyphs, or (2) get the free Trace Image plug-in from Window > Plugin Manager. After installation, Filter > Trace image will try and produce vectors based on the image that has been dragged and place in the master layer (no SVG or iColor layer necessary in that case). Once you run it, simply experiment with the number settings:

16

Great, I just tried to make a character.
very good
Does this mean that I don’t need as many steps as above?
I just need to put the png file first and then trace the image and finally delete the png image.
I can finish my font.
Can plugins write scripts to batches?

Oh god
I think I solved this problem.
I can now use the png file batch to do the font file.
Thank you so much.

One more thing
I am already done.
But I get an error when I export OTF
like this


But can successfully export ttf
How to solve it?

The outlines created with the Trace plug-in are complex. This has certain implications, e.g., you cannot hint them and you may need to disable subroutinization. Here is how you do that:
https://glyphsapp.com/tutorials/creating-fonts-with-complex-outlines

Just to clarify: You don’t need to place the .svg files again. The SVG that was generated from Glyphs contains the png images you had before.

I solved this.
The font file I exported
I can’t find it in word after installation
But I can type it in textpreview
I have already installed it in the font book. Is there a problem with my installation or a problem with the file?
How can I solve this?
Thank you, I am getting closer and closer to the goal.

I think I don’t need this method.
Direct use of plug-in trace image
It seems simpler?
Or that way has a better performance worthy of me to do
Thank you still

Unfortunately, font installation is not as straight forward as it should be in macOS. Please read this:
http://www.glyphsapp.com/tutorials/eliminating-font-cache-problems

Ok
I will study it later.
But if that I want to promote it
Is it so troublesome to use on windows?
Why can’t it be like other fonts?
Can be used immediately after installation

You need to test your font.

What is the purpose of the test?
I have no problem looking at textpreview.

I opened it with a font book. It is so blank.
like this


Is this normal?

Cleared cache
Still can’t use on word
I want to make it available after installation (just like the fonts downloaded on the web)
No need for so many troublesome steps
what should I do?

thanks

Try exporting it with a different name in File > Font Info > Font

That should take care of it if it is a font cache problem. Read this please:
http://www.glyphsapp.com/tutorials/eliminating-font-cache-problems

I have already made the font.
But there are still some small problems in use.
at first
On the mac system, when I typed bopomofo to form a Chinese character
(bopomofo is the major Chinese transliteration system)
Will be automatically switched to the default font
At first I guess I didn’t put bopomofo in glyphs.
Later joined bopomofo and other common symbols
This problem is solved on mac system
But still on the windows system
How can I solve this?

And I found the size of my Chinese characters.
(My font is too small)
Does not seem to be the normal size of other fonts
like this


This is another font on the web

Then I would like to ask what is the normal size of Chinese character?
How can I solve this?

The size of the letters depends on the relation of size of the drawing to the fonts UPM. You can use a smaller UPM (like 800) and export again.

Office software will typically switch to a fallback font if the font is missing a character. Please double check your character set.

I solved it

I think I made up the missing part.
And this is working properly in the mac system office.
But in the windows system office, it will automatically switch to the default…