"Copy Layer to Layer.py" does not work


#1

I updated glyphs 2.5b (1094) and installed modules form the add-ons install panel.

Then, I run “Copy Layer to Layer.py” of Glyphs-Scripts/Masters.

The setting window of “Copy Layer to Layer.py” appears and “Note: ‘Copy Layer to Layer’ could not load preferences. Will resort to defaults.” is printed on the Macro panel.

The cursor becomes the rainbow progress, and then it never comes back again…

I restarted Glyphs.app and tried again, it was the exact same satiation.

Is that reproduced on your machine?


#2

I use that script often and just tested it to see if it still works for me in 2.5b [1094]; it works as it always has.


#3

Thanks for your confirmation. It may be reproduced on only my machines, I am not sure what is wrong…


#4

How many layers does the file have?


#5

I belive it is not depended with layer or file status, the script always freezes in a few seconds just after it runs.


#6

Did you make sure you have the latest version?


#7

Also, what exactly are you trying to do? Would Edit > Paste Special (Cmd-Opt-V) work for you? (Instead of the script.)


#8

Thanks for your comments.

It seems to not improve in the latest (probably v1095).

Could you deliver an option that allows me to copy and paste Smart Component glyphs within all of sub layers defined as axes at once?


#9

I could know this obstacle is avoided by comment out “NSUserDefaults.standardUserDefaults” setting in “LoadPreferences”. I am not sure, but this class might no long be compatible with the recent Mac OS…


#10

The former comment seems to be not exact, it will better to comment out around save and load preferences.


#11

The classes are not obsolete. This points to a file permission problem.

If you want to copy layer structures, try Paste Special.


#12

I made Smart Components in Regular and created some glyphs at the first.

e.g. _part.test has the follow layer structures :
Regular
Width
Height
Sreif

And then, I added new Bold master at the next. The Layer structures of this component will be :
Regular
Width
Height
Serif
Bold (empty)

So, I would like to copy each Regular structures to corresponding Bold structures.

Regular
Width
Height
Serif
Bold (copy Regular)
Width (copy Regular Width)
Height (copy Regular Height)
Serif (copy Regular Serif)

If a Smart Component contains Conner Components, I need to copy them too.

Does Paste Special allows me to do that?
And I am wondering if you could tell me how to revise the file permission error.


#13

You can do that in Finder:
https://support.apple.com/kb/PH25287?locale=en_US

Pay special attention to your Library folder, and the Preferences folder therein.


#14

Thanks.


#15

Look at the file “com.GeorgSeifert.Glyphs2.plist” in my home/library/Preferences, it seems to already have a suitable permission (owner:read/write). Which file should I revise ?