Copying Uppercase from one font to replace the uppercase in another font

I am trialing Glyphs and have looked carefully at the documentation already as far as I can tell.

I want to replace the only the uppercase in one font with the uppercase from a a second font. I don’t see to be getting the desired result using Paste Special no matter how I have tried. They always seem to be added to the end, but have a different naming scheming.

How am I to accomplish this?

I just tried it, and this works as expected in 2.3.1 (919):

  1. In the source font, go to Font View > Sidebar > Categories > Letter > Uppercase.
  2. Edit > Select All (Cmd-A) and Copy (Cmd-C)
  3. In the target font: Edit > Paste Special (Cmd-Opt-V) with these options:
    • Paste to: Glyphs with the same name
    • All data

When I do that (which is what I had tried already), all the lowercase gets replaced also? My version is 2.3 build 895.

When I try selecting highlight the specific glyphs and clicking 'Selected Glyphs" the same thing occurs.

Are the lowercase components of the uppercase? If so, you need to decompose them first.

Hmmm. Maybe I’m not understanding what you mean by decompose? There are upper and lowercase glyphs in the file that I am copying the uppercase data to paste in the other file:

Open one of the lower case letters. Do you see nodes and paths or a gray shape? Probably the second. That are components. They refere to whatever is in the linked-too letter. Decomposing them means to break that connection and copy the outline into that glyph directly.

This is the upper case. I meant the lower case like ‘a’.

This is the

This is actually the file I’m trying to copy into. This must be what you are talking about.

Yes. So you are putting in the components. Same thing. Copy the lower case and paste it in the uppercase slots. It decompose the source fonts before you copy.

So I don’t have to (or shouldn’t really) select Decompose components…just do each glyph one at a time…