Corner components broken?

I just tried adding a corner component to a glyph. I did the inktrap exactly as you show in the article Reusing shapes: corner components | Glyphs but the inktraps do not show up in the glyph they are used. Only blue rings are shown. Also when deleting the corner components I have to select each node to which they were assigned, and hit delete many times to get rid of them. It feels like a bug.

NB: I can apply the corner to an outside corner, it just doesn’t show in an inside corner.

Path direction?

Can you send me the file?

the file has

Font.previewRemoveOverlap = False

That removal of overlap is needed to be able to apply the corners on intersections. You need to enable it with this code in the macro window

Font.previewRemoveOverlap = True

It should work on export in either case.

1 Like

Thanks Georg. It’s a very old file I’m updating, but I would never have found that Font.previewRemoveOverlap on my own.

Oh, and yes. It works now.

Hold on, I just restarted my Mac and I had to do this again. Will I have to do this every time I restart Glyphs? Can’t we please have that set in the Preferences? Or perhaps for each file?

And a nota bene: Please let us have ‘Add Corner Component FOR ALL MASTERS’ like we have Open Corner &c for all masters. Also please let us have the possibility to select both regular nodes and extra nodes at the same time and then apply Corner Components. We can’t at the moment and it is a gargantuan time waster.

1 Like

You need to manually hit Cmd+S after you change this setting as it isn’t “dirties” the document so it doesn’t know about that it needs to save.

I am pretty sure I saved the file after running it (but I don’t have time to test it now).

I checked again and the setting is connected to the “Variable” setting in Font Info > Others.

Alright, that was on. I also did a quick test, and the running of the code does not stick – even when saving the file after running it – and then restarting Glyphs. I’m on 3207.

The ‘Variable’ setting overwrites the preview setting on opening the file. So you need to set the font type to Default and run the script.

and then turn Variable back on after that?

missing anchor

Of course – why didn’t I think of that? Because the layers were just ordinary layers before I turned of the smart layers, where they need to be compatible. Very silly of me.

Side question: Is it somehow possible to set these corner components in glyphs built from components? I’d love to have that possibility. You can see the issue here:

That would be great, wouldn’t it :wink: