Correct me if i am wrong exported OTF

I’ve export OTF and installed to my computer. My question is, when i open the font in Adobe Illustrator it show many classes in glyphs panel.

It really different with another OTFs i have and installed on my computer. It just show Alternates For Current Selection and Entire Font.

Anyone willing to corrected me if i’m wrong or miss the step in exporting/making this font? Or i am still in the right way? Is it possible if we fix this in font info?
And the last question is… This OTF features can’t opened in my coreldraw x6.

PS: This font is normal for use and i can using all my stylistic alternates with my Adobe Illustrator CC but not in my coreldraw x6.

I am not aware of a Glyphs tool in Adobe apps. I assume you mean the Glyphs panel? What is shown there depends on your selection and the available OpenType features in the selected font. If the OT features listed there are in your font, then everything is fine.

Perhaps the fonts you tried do not have any OT features. I just tried with a few OTFs, and they all list their features:

Am I missing something, or what exactly is the problem with OT features being listed for the user? If it didn’t list them, I would be concerned. But your font’s features are listed, right?

I am sorry, yeah it’s means Glyphs Panel. Thanks for your reply, really appreciate it. How about coreldraw’s problem? Do you have any idea how to fix it?

I don’t have CorelDraw. Have you tried in the Corel support forum?

Not yet but i will. Thanks in advance

By the way, how to make all list like your attached image? In my case is, is it possible if put all my ss01, ss02, etc to the one list?

The problem in my coreldraw, i think is .ss01 code. This code could be available but by manually.

Like i did, i can change the letters “l” to be my .ss02 feature.

I found another .otf file and have try it in my coreldraw x6 too. And the result is have no problem.

All features are available. The problem is we have different coding or do you have an idea for this case? Thanks in advance.

Make sure the aalt feature is up to date.

Keep to push refresh button in font info isn’t it?

Yes. Check if one line in it reads feature ss01;

Like this one? Do you have any suggestion to change my .ss01 code? The .ss01 feature is looks like my letters, “l” in above.

That is fine. I assume the error must be either in the font installation or a bug in the app that is using it.

I just realised if i’m still using this glyphs in trial version. if this is the causes?

No, it is the same app.

Then, do you have any suggestion about this problem?

In this image, my feature is not available but it works when i change my “l” in standard character to be l.ss02

This is completely different to what is supposed to happen. Please visit in [here] (Knowledge Base) to see what is supposed to happen. Thanks in advance.

By the way… in my otf, i have standard ligature feature in it. When i select the fonts, It works. But again, the corel says, “this feature is not available for the selected font.”

Just for information, i’ve install another otf file to my windows with the same steps. Then i open my coreldraw, and again it works and it’s what is supposed to happen. All features are available and corel says, “this feature is available for the selected font.”

Any help or suggestions greatly appreciated. Thanks in advance.

I could only make suggestions about the font installation. Did you clean font caches before restarting the OS?

Have you contacted Corel support?