Correct Path Direction for all Masters doesn't apply to smart component layers

Hello, I noticed a rather specific bug: If you use the Correct Path Direction For All Masters command, it doesn’t work for smart component intermediate layers. If you use it without Option (so not for all masters), it works for the currently viewed (smart component) layer.