Correcting Master Compatibility


I’ve created two simple masters with special symbols that should interpolate on a weight axis.
When using View>Show Master Compatibility the two masters will show me the glyphs with problems.
How can I correct the “lines” from one node of master 1 to the correct node in master 2? (I’ve tried to use “correct path direction” and set the correct first node on both masters first)

BTW it seems that there is an error when rotating. I’ve first drawn the above example with vertical and horizontal stems. Stems were 120 units thick and of equal length. After rotating 45 degrees the lower points were not exactly placed on the same y-coordinate. The left one was on y=0, whereas the right was on y=1.


For some reason the bolder master seems to have an extra node at the lower right.

And for the rounding of the rotation. Can you send me the original shape. What might have happened is that the internal higher prediction representation was slightly off. Can you try to save and reopen the file before rotating?

yep, this was the reason! Don’t know where this extra node comes from … anyway, see attached file for the unrotated “cross”. If you rotate 45 degrees and then rotate back the coordinates changes from the original version.
test_rotate.glyphs (8.9 KB)

The plus is not 100% symmetrical. This might cause this.

you’re right. I did not pay enough attention to absolute exact placement of nodes. Thank you.

just one question: I have a glyph with to parts, a circle and above an arrowhead. When showing master compatibility one arrowhead is connected to the circle in the other master and the circle to the other arrowhead. How can I order the paths correctly?

Have you read this:

Thanks, yes, I’ve read it. And I have solved it. I just cut (cmd-x) the arrow then the circle got the right connections. Afterward, I copied the arrow back in and everything was fine.

I’ve already tested the font with InDesign 2020. It works quite well except for two or three glyphs that interpolate wrongly.

Does there exist a standard procedure to find the source of error?

Try the mekkablue scripts Find Shapeshifting Glyphs and Travel Tracker. They help you find these cases.

Otherwise, step through all the glyphs, with Show All Instances in the bottom preview area, and you should be able to spot these cases. There should be a paragraph about this in the tutorial.

Thank you very much, I will look at these. BTW I’ve tested the font on the web (Wakamai Fondue) and there everything looked o.k.

This is a path order and/or start point error.

I’ve tested with the mentioned scripts which resulted in no errors/warnings. I’ve checked the paths (first node, directions) of the wrongly displayed ones. Everything looks o.k.
Strangely I got different results on a Windows machine and on a Mac. I will have to investigate further to find the problem.

Thank you very much for your help. Much appreciated!

If you see different results like this then you have a cache problem on either platform.

I suppose you are aware of this tutorial?

On the Mac side yes. It also seems that there’s now a bug in the latest ID for Windows because fonts in the “Document Fonts” or program “Fonts” folder did not show up in the font lists … (I’ve reported this to Adobe)