Could not open file (863)

I have opened two files with interpolationWeightY, tried to export one of them.
Glyphs crashed and now I can’t open neither in any version of Glyphs, from 1.4.4 to the stable 2.2.2 and the latest cutting edge (863).

Does anybody else found this issue?

@georg - I have sent you the files via email but wanted to post to check if someone else have the same issue.

Many thanks!

instanceInterpolations = {
“5FC5030F-1735-4A41-94B9-E646D034358A” = 0.15;
“495A1A92-CBBB-4418-948E-DD5B1DC09B9F” = 0.883913;
“A2FDA749-8346-4E3F-B9FA-CC0571C8175D” = -0.033913;

I have removed lines like this + interpolationWeightY by hand using a code editor in a test file and surprisingly the files opened regularly this time.
Still, I might have messed up other things in the file since I know very little about the glyphs file code. And for example a Black instance shows as a weird condensed icon (there are 4 masters in the file) with a black + thin preview in the instance panel preview. Anyway, weird :).

Saving a file on the cutting edge version of Glyphs seems to render the file useless.

Not sure if it’s true but it just happened to another file.

Build [863] saves files and reopens them just fine for me.

There is a bug with files that have a interpolationWeightY. I have fixed it. The files can be repaired.

Thanks Georg,

The file is recovered (THANKS) and now opens and saves fine in 864.

But… I’m still having crashes 100% of the time exporting the files in the cutting edge (864).
2.2.2 (Stable) is exporting fine though.