Crash when creating Korean glyph from filter list

Hello –

I have an easily reproducible crash in Glyphs 2.3 (895): if you have a filter list that has Korean glyphs in it, and they’re missing from your font, hitting Generate from that missing glyphs fly-out menu crashes Glyphs. I’ve tried it on a few fonts over here and they all crash.


In fact, you can create a new blank file and generate Korean glyphs either from Missing Glyphs fly-out menu in a filter list, or from writing in the glyph names in the main Add Glyphs… function. Doing it both ways causes Glyphs to crash.

Did you send the crash report?

I can’t reproduce it. It might be that you have a font installed in that interferes with the system font. But maybe I have fixed the problem already. Can you try the latest cutting edge version?

Yes, I sent the crash report. There should be three in a row, in fact. :slight_smile:

I will try the latest version tomorrow. How do I find it? The updater says I am up-to-date.


I just tried with the 2.3 version and it did crash. but the latest cutting edge version is fine.

How do I get that version?

You activate it in the Preferences > Updates. But duplicate the app and rename it to “Glyphs Beta”. That way you can use the stable version and the cutting edge version at the same time.

Great, thanks! I’ll report back if I have further issues.