Crash when turning on the presenter script

Gyphs crushed When I tried to turn on the Present script and now Glyphs is not wprking at all.

Please send those crash report and add a note pointing to this forum thread.
What version of Glyphs do you use?

You can remove the plugin by opening this folder in the Finder:

~/Library/Application Support/Glyphs 3/Plugins

(in Finder, “Go” menu > “Go to folder…” > paste the above string)

Then remove the Presenter plugin. Then Glyphs work again.

I use Glyphs 3.

I solved it by reinstalling the program and deleting the script.

Thnak you.

The re-installing was not needed. Just remove the plugin/script.

Well, just removing the plugin for ever is not really a solution if you actually want to use it.

Of course it is always good to report such things to me, so that I can see to fix it. On my machine it does not crash, so let’s try to fix it for you.

Could you ever use the trial version?

Which Glyphs version do you have – the build number (e.g. 31XX or 32XX)?

The plugin in the ”Plugins” folder is called ”Presenter Pro.glyphsReporter” and in the ”Repositories” Folder is a folder called ”presenter-pro-plugin”. Those both you would need to delete.

Lastly, could you check if you have a ”paddle-framework” in the ”Repositories” folder as well?

Then, maybe installing it helps?

Thanks so much for your patience and sorry for the inconvenience.

@GeorgSeifert @FlorianPircher

When I talk to users with crashes via email, it almost always turns out, that manually reinstalling the mentioned items (plugin, repository and paddle framework) helps. Also the plugin version they have is almost in every case older than the one that is deployed and live.

I reported often to you, that the plugin manager does not pull the latest version for users. It is really a problem, that the latest versions don’t get to the users. Can you please have another look into that?

Just to add to that, I also updated a plugin already available through Plugin Manager, and was wondering whether Glyphs is going to update it automatically, but it doesn’t seem to.

I am glad to know I was not alone. And given that Presenter is an instant crasher in my environment, I had thought Mark should have experienced it already (wrong beginner assumption :sweat_smile:)

At least in my case, manually installing paddle-framework fixed the issue. The Paddle window opened, which I didn’t know was the expected second screen and I understand why that was to blame (I was thinking it was surely not licensing fault because it was already applying the fancy visuals as soon as I turned on the plugin regardless.)

I think it’s a good idea to catch the error and show me an instruction or something instead of crashing for eternity (until I remove Presenter from preference plist, which is a very beginner-unfriendly solution. That said, I disabled the failsafe option myself tho).

1 Like

I just checked the automatic update process and it works for me. But only if there are no changed files in the repositories.

Does it work for you now, Toshi?

Sorry for the inconvenience. I will try to get those crashes out. Georg recently showed me a way to better debug such crashes, but the set-up requires a lot of re-work and change, which I had not much time to really dive into yet. It is very high on my list to do. (Especially due the high number of my plugin fleet, which is a blessing and a curse for me).

@GeorgSeifert Do you have an idea how we can force fetch the paddle framework for the users? Maybe once in a while? They released a new version which adresses Sanoma, and I’ll have to update the framework soon-ish, which also requires some changes in the plugins, hence I rely on that the right framework version is loaded.


What do you mean with ‘no changed filed’? Isn’t that exactly a case, where I want it to pull the updates from the repo? :slight_smile:

Had a talk with Georg, and we are working on a solution for my last post’s questions.

Yes, it works now and have purchased the plugin. Thanks!

Thanks for letting me know and thanks for your support, Toshi!