[Crash] When using pencil tool (2.4.1)

Make sure you always send the crash report:

Thanks, I did in an earlier message in this thread (the attached PDF). This was just a follow up.

No, please do not attach crash reports to forum posts or emails, please use the dialog that comes up after you restart the app. For more details, please take a look at the tutorial: https://glyphsapp.com/tutorials/crashes

I understand, and will do so in the future. But if you read the thread, you’ll see that for some reason I didn’t get the crash report window and was asked to copy/paste the content. (I know you all juggle a ton of these forum posts. Thanks.)

I still need to know your current version.

Recently updated to Version 2.5b (1072)… but this first occurred while using 2.4.2 (1045)

Hi @GeorgSeifert

We’re encountering the above pencil tool issue on Version 2.6.1 (1230) and Version 2.6.2 (1257).

To recreate:

  1. Create a new document
  2. Open blank glyph
  3. Using pencil tool, draw without releasing mouse for several seconds
  4. App crashes

As with above, we’re not seeing a Glyphs crash report dialog. Only seeing the Apple one. Thanks!

pen tool crash report.zip (27.1 KB)

I can reproduce this. But I have to draw a lot until it crashes. It seems there is a maximum length of the path that can be drawn…

I am using a MacBook Pro running MacOS 10.14.6 Mojave, I have installed both demos, Glyphs Mini Version 2.1.3 (99) and Glyphs Version 2.6.2 (1268), I am using a Wacom Intuos Pro tablet. Both versions crash when using pencil tool, I simply select the pencil tool and start drawing a single shape to reproduce the error. I cant currently complete the letter E without it crashing. I get asked to send Mac an error report but not to Glyphs so I cant raise the issue with them. This has been a consistent error for some time by the looks of it, certainly since version 2.4.2 (1045) according to Adam… Very disappointing.

the problem is the Wacom driver. It produces an unexpected stream of events. All driver versions i tried are fine so it is very difficult to debug.

I get a crash after pencilling moderately long lines, and I do not have a Wacom.

Have you tried the latest beta?

Yes this is with 2.6.3 (1270).

Can you send a screencast?

1 Like

yes, this is exactly whats happening to me Eliason, thanks for posting this.

Sad to report this is still happening to me in Glyphs 3.0.3 (3059)

Thanks for the reminder. I fixed it.