Creating a font with no "space" character

Whenever I export a font, even when the “space” glyph (unicode 0020) has been explicitly removed, the export process adds it into the font by default. Is there an option to stop this from happening and maintain the fonts space-free? If there is a script for it, I’d appreciate some guidance in finding it. Thank you!

I believe .notdef and space are required. Why do you want to remove the space?