Ctrl-Z crashes Glyphs

In Glyphs 2.4 (939), when I try to undo something using Ctrl-Z, Glyphs sometimes crashes. This occurs intermittently, and is difficult to reproduce. I bought the full license for Glyphs in January, 2017. This never happened before I installed the license. It is problematic because I lose the font prior to my changes.

I have attached the crash report.


Crash Report 2017 02 13.pdf (75.0 KB)

Can you try the latest Cutting Edge version and see if this is already fixed?

It still often happens when undoing a ‘transform with background’. I’ve been sending error reports for a very long time.

@RaoulPat …which reminds me: do not paste crash reports here in the forum, but send them via the dialog that pops up after you restart the app. See the first chapter of the handbook for details.

I think I’m using the latest version. When I click on Glyphs - Check for Updates, it says “You’re up to date. Glyphs 2.4 is the latest version.” Yet Glyphs still crashes sometimes when I use Ctrl-Z. Frustrating.

2.4.1 is the very latest version. In your Preferences, click the checkbox that says “Show cutting edge versions.” Then click “Check Now”.

Upgraded to 2.4.1. Will let you know if it crashes again. Thanks.

After upgrading to version 2.4.1, Glyphs still crashes intermittently when I use Ctrl-Z.

Make sure you always send the crash reports, otherwise we cannot fix the crash. If you can reproduce it, please add that to the report or describe the steps for reproducing the crash here.

Make sure you can exclude both the .glyphs file (try with other files) and plug-ins (disable all plug-ins and try again) as source of the crash.

What did you do the the glyph before you undo. Can you make a screencast: Open a file change something > undo > crash?

Those undo crashes depend very much on the context and the file, so I need very specific information to be able to reproduce it.

I have enclosed the crash report and a link to a screen recording of the crash. This occurs when I type Ctrl-Z while editing “textura test.glyphs.” I am unable to reproduce this with a new .glyphs file. I have the TraceImage plugin, but do not know how to disable it.
Screen Recording: https://drive.google.com/open?id=0B2T5yt2alfsRSzhsRUFNZEZHWmM
Thanks.Crash Report 2017 02 28.zip (22.2 KB)

After removing the TraceImage plugin, Glyphs still crashes. I have enclosed another crash report.Crash Report 2017 02 28 1700.zip (17.3 KB)

Please do not upload crash reports here in the forum. Instead, click Reopen in the dialog that appears right after the crash, let Glyphs restart, and confirm the dialog that comes up after you restart Glyphs. If possible fill in your email address so we can get back to you in case we need to look at the file.

One piece of advice: after a crash, restart the app by clicking on the app icon in the Dock. It will try and reopen the documents you had open right before the crash. Do not open and edit the Autosaved file, let the system handle it (it is used by the system for recreating the latest state), because you will end up with multiple versions of the font file, and file management will get increasingly difficult.

Can you send me the file?

I just resent the problem report. Do you need the .glyphs file?

Yes. The .glyphs file would be good. Thanks.

Hi, Georg,

I have enclosed the Textura Text.glyphs file as you requestedTextura Test.zip (85.8 KB)


Any progress on the Ctrl-Z crash issue?

Can you try the latest cutting edge version? I fixed a undo crash recently.

Thanks, Georg. Thanks seems to have fixed it.