Custom ink trap axes not working on indesign or online font gauntlet

I made an axis for ink traps to go from none to ink trap and I made a halfway instance and the three variables work on glyphs, however when I use on adobe or an online variable tester, nothing happens when using the slider.BeanSansInktrap-Variable2.glyphs (250.1 KB) DumboGX.ttf (13.1 KB)

Also when I export any files my 7 specifically gets messed up and changes shapeBeanSansGX.ttf (64.6 KB) DumboGX.ttf (13.1 KB) image

edit used opsz for the axis and now works, but 7 still doesn’t export right for any face not just this one.

I downloaded your font and I didn’t have that problem in seven. i tried it in illustrator and indesign and it didn’t give me that problem. maybe you need the adobe update (? I don’t know.
but be careful with the 0 handlers, that could also cause interpolation and export problems.04

Also be careful with the repeated points, that can cause problems


the repeated parts have to be there for the ink trap to work, for some reason in Font Book it does that and saves it like it for the 7.

try moving the handles, it works fine for me.

I recommend you leave them like this

1 Like

a restart on my computer fixed the problem with the 7