Delta and Omega Automatically Double Encoded?

Version 2.5.2 (1184)
If I create /Delta and /Omega glyphs, they are automatically double encoded as 0394 (Δ), 03B4 (δ) and 03A9 (Ω), 03C9 (ω), why is it getting the lowercase encoding too?

If you create only a cap and update its glyph info, it gets the lowercase encoding too. The software assumes that you are creating an all-cap font and adds the corresponding lowercase codes. The glyph then survives casefolding when the user converts a text between UC and LC.

Seems a bit of a reach to do that without the option to disable it.

  1. You can delete the second Unicode.
  2. Glyphs does not do that by itself, you must actually run Glyph > Update Glyph Info.

I think it’s too presumptuous. At least if the font then also has the lowercase glyphs, the uppercase glyphs should lose their lowercase encoding.

It was supposed to clean the second unicode when a lowercase was added. That was broken.