Deselecting glyphs in font view unreliable

This is a minor, but still bugging thing:. When I select a glyph (or multiple glyphs) in font view and then try to deselect it with right-click (command+click) it only works one out of eight times.

I use an apple magic mouse and have it set to no right click (hence command+click). When I use the Macbooks trackpad, all works fine. And PLEASE, no schooling or complaining about hardware use. I don’t care if there’s better options, I like my setup :blush:. I just wonder, if there’s a way to fix this…

I remember, there was a discussion about selection responsivity in the font view, a while back, and I beliefe to remember that somethings were changed after that…

Can this be fixed?

Right click and Cmd-click are two different things.

You want to change the selection with Cmd clicking? The problem with many magic mice is that it is hard to tell if you are statically clicking or dragging or doing a swipe gesture on the mouse. The only remedy I can offer you is to deactivate inertia in System Preferences or deactivate the swipe gestures you don’t use.

of course, you’re right, my mistake!

What I’m referring to is the way to deselect a previous selected glyph by pressing cmd+click. What’s so weird about it is, that it looks like the click would be to fast to be registered (or like a doubleclick), as it deselects and selects the glyph right again. Like the program would change it’s mind and decide that the input doesn’t qualify as a click…

I believe I was the one who started that topic: Magic Mouse in MacOS Sierra

The problem was that I was dragging the mouse slightly when I clicked. This particular problem has been fixed (for selecting glyphs). However, I can confirm it is still a problem when deselecting glyphs with Cmd-click.

1 Like

Oh, should have made a search before creating a new topic…

glad to know though, that I’m not the only one seeing this!

I’m wondering if this minor bug/issue is ever going to be fixed. Deselecting a glyph in font view is a real pain ( drives me nuts tbh :slight_smile: )

Upd: the only way I’ve found for this to work properly is to completely stop your mouse before cmd-clicking the glyph. It used to work just fine month ago, you could deselect “on the fly”, there was no need to “sit and relax” before the cmd-click


1 Like