Did something change within the filter code?

Hello, with absolutely zero change to my code, suddenly, mutliple of my filters are giving me the same error when I try to use the stepping text field:

It works fine in plugins by other people :sob:

Any help is much appreciated!

You are using build 3133; try updating to 3138, uploaded 9-23.

1 Like

Updating to 3138 didn’t change anything, sadly. I still get the same error when trying to enter a value in the stepping text field.

This is really annoying, as I haven’t changed anything at all in my plugin code (also checked with an older plugin I haven’t touched in a few weeks, same issue).

@mekkablue Did you’d have an issues like this recently?

For example, I have the following:

	def setAngle_(self, sender):

I get 0.0 for every time I change the value. sender is a float value (always 0.0), for some reason. Why/when did this change and how tf do I fix this?

Hello again, sorry to bump this, but this is really driving me mad. What can I do to remedy this?

It appears that the current implementation is broken, but I am not sure where. When I try to retrieve sender, it always returns -32.0 instead of the GSSteppingTextField in question.

Same thing if I change the type of the UI element to something else. :confused:

Ouch. Why is this not an issue in, e.g., RMX tools? Or built-in Glyphs filters?

Thanks for the info. Why/when did this break? Is it a macOS-related thing? Or Glyphs? Or something else?

Investigating… don’t know yet.

I think it has to do with the nib loading. Can you send me the plugin? I’ll have a look.

It’s the plugin at

Thanks a lot!

What version of macOS do you have?

macOS 12.6

Of cause it works fine for me.

I don’t really know what caused the crash but I could change something to avoid it.

Thank you very much!

I still get an error, sadly, the plugin doesn’t seem to work anymore:

Traceback (most recent call last):
  File "GlyphsApp/GlyphsApp/plugins.py", line 447, in setup
  File "plugin.py", line 66, in start
  File "plugin.py", line 97, in set_states
    self.angleTextBox.setStringValue_(Glyphs.defaults["com.eweracs.italify.angle"] or "0")
ValueError: NSInvalidArgumentException - -[__NSCFNumber isEqualToString:]: unrecognized selector sent to instance 0x600005ebf2c0

Edit: this is somewhat resolved, don’t know why.

There was a mismatch between numbers and floats and what setters where used and what was stored in defaults.