Different glyph sorting on Adobe apps and Apple apps

I’m having issues with a display font I’m making for a client. Its an unicase font with double unicode on letters (A-Z), with 3 stylistic sets and dozens of Dliga.

It works fine with Adobe (AI, ID, PS). But with Apple (Pages, Keynote) and Font Explorer it changes glyphs order.
Instead “SPACE” it shows “€”. Instead “&” it shows “©”.

I guess the different programs are rendering the unicode charts differently. Although not sure…
Do you have any idea of how to solve this?
Thank you guys in advance.


There you have a nice example of a corrupted font cache.

Hi Georg,
I have cleaned font cache but it persists.
The font file has been installed in 4 different macs (with no previous versions of the font) and the same problem happens. Other ideas?
Thank you!

Can you send me the file?

Just sent it on a private message.

I got it to work. There was indeed an encoding problem. Here is what I did:

  1. In Font Info > Other Settings, disable Use Custom Naming.
  2. In Font view, select all glyphs and choose Glyph > Update Glyph Info.
  3. Repeat step 2.

And export. Again, do not install your font for testing. Rather, use the TextPreview app from the Tools section of this website.

Hi @mekkablue, thanks for your prompt reply.
We have tried your suggested workaround (in two different computers) and got the same bug. No changes.
Now we have made a copy of the .glyphs file removing all ligatures, diacritics and rebuilding the opentype (automatically ) and the font performance is as expected (no wrong glyphs, and space working fine) although we lost all the .dliga.
Do you have any extra tip?
Any advice is appreciated,

How do you test your font?

  1. Cleaned fonts caché (twice, one with terminal and another one with Applescript)
  2. Erased manually any existing .otf of the font
  3. Performed your instructions in Glyphs file with a new file name and family name.
  4. Exported to Adobe Fonts folder
  5. Checked with Text Preview
  6. Doesn’t works (see attached image)

I will try again today. I think I also rounded the coordinates of the nodes. That should be unrelated but who knows.

Just to make sure as you didn’t mention it: Did you restart your Mac after cleaning up?

yes I did it twice, I cleaned cache using the terminal, restarted, cleaned again with the apple script and restarted again.

1 Like

Hi @mekkablue and @GeorgSeifert . I tried rounding coordinates as Mekka said and it worked! :smiley: Thanks a lot for the support!