Disable CmdN shortcut

There is a shortcut I use frequently: Cmd + B, to switch between the background and front layers. I often type it blindly. However, as you can imagine, I encounter a new font window many times. Too many times. Is there any trick I can use to disable Cmd + N in Glyphs? It could save me a lot of time. And cursing.

1 Like

Haha, I have been wanting to write a lengthy rant about this exact issue many times, for exactly the same reason.

I just checked, you can simply delete the shortcut for “New”. I just changed it to Cmd+Shift+N.

1 Like

Ha!, thank you Sebastian.

(edited) Nope. Shortcut CmdN deleted in Glyphs > Settings > Shortcuts with no success.

Deleting does’t work, indeed. But assigning something else works.

Thank you, this has been bugging me forever too!

Bad. In this case the only solution is to reasign CmdB somewhere else.

Why? You can assign a different shortcut to “New”. Admittedly, this is not an ideal solution, but you can make it something that you won’t hit accidentally (such as adding Shift in between to make it Cmd+Shift+N).

But this does not disable plain CmdN. Does it?

For me, it does. Does your shortcut menu look like this?

Hm? Not on my computer right now. Will try tonight, merci.

Cmd Shift N assigned to File > New. It doesn’t work. But Cmd N is still active. Alive and kicking.

You currently still need to relaunch Glyphs for any newly assigned shortcut to be effective.

Did it. A few times.

Hm, I just tested it and it works for me. What keyboard layout do you use? US, ISO …?

Or get a split keyboard (which I would recommend anyway to anyone, due to ergonomics) and you will never ever miss N and B, because the split is usually between those 2 keys :grin:


Wireless ISO. Solved. Had to restart Mac, but it seems it work now. Thanks everybody.

Could you try setting the shortcut in the System Settings app? Go to Keyboard → Keyboard Shortcuts → App specific shortcuts. There, add a Shortcut of, for example, ⇧⌘N for “New” (the name of the menu item in your Mac’s language).

Apple’s system for setting shortcuts is not accessible to us developers, so it would be interesting to know whether that method works for you,

Thank you Florian. I also considered using App shortcuts, but now that it works with local Glyphs shortcuts, let’s save that for another time. Or problem.