Disable measurement tool's ability to show coordinates

Is it possible not to see x,y coordinates of the nodes and BCPs while using measurement tool? Maybe being able to turn off and on “show coordinates” would be a good idea.

What for? Would Show Stem Thickness help in achieving what you are aiming for?

Show stem thickness doesn’t work in the same way for me. I often measure spaces and stems or more than one stem at the same time.
I thought it would be preferable not to see so much numbers while measuring things if it is possible.

This is still showing some numbers (more or less depending on settings), but at least not the coordinates of all the nodes. Maybe closer to what you’re after?

Or switch a guide to measurement mode. Or, use the stem measure option in the Crosshair plug-in.

@Mark Thanks I will check it out

@mekkablue Crosshair might work but its show thicknesses doesn’t work. I got this error message in macro panel

Traceback (most recent call last):
  File "GlyphsApp/GlyphsApp/plugins.py", line 1135, in drawForegroundForLayer_options_
  File "plugin.py", line 116, in foreground
TypeError: Need -1 arguments, got 0

Which exact version of Glyphs are you using? And which macOS?

Edit: NSColor.separatorColor() is only available in systems 10.14 and later. will see if I can add a workaround in the code.
Update: fixed. Please uninstall and reinstall the plug-in through Window > Plugin Manager.

1 Like